Install PHP5 on OpenBSD 4.2

PHP needs expat; this is included in the base set xbase42. If you didn’t install it at install-time you can get it with

cd /
ftp http://ftp.belnet.be/mirror/ftp.openbsd.org/4.2/i386/xbase42.tgz
tar xzvpf xbase42.tgz

2 thoughts on “Install PHP5 on OpenBSD 4.2

  1. Do you have to reboot after extracting? I’m trying to install apache and I’m getting the expat error. I really don’t want to have to take the server down…

Leave a Reply

Your email address will not be published. Required fields are marked *